Duplicate File Validation error during Process Lockbox when import file is not a duplicate



Description of Issue

I am running the Process Lockbox File and getting a Duplicate File Validation message



Context
  • Process Lockbox

  • Mail Payment Processing

  • arlckbox

  • arpmtimp

  • armalpmt



Cause

The Duplicate File Validation process during Process Lockbox was fixed during a recent update on (MUN-433206 that became available on 03/17 or corresponding ticket for Munis version) and now validates correctly against information in the file header. Previously this warning was not appearing due to an issue with how the validation was handling bank codes. It is now is checking for any receipt header records created by Lockbox within the last 13 months from the current batch's entry date that have the same external batch number and bank code and providing prompt for Duplicate File Validation if it finds an instance where the batch number in the current import is the same as a previous import file. 



Resolution

To resolve this issue the following steps can be used.

  1. Verify that the lockbox file being imported is not a duplicate of one that has been previously imported. Once this is confirmed users can choose the option to continue and import this file.

  2. To prevent this prompt from appearing in future attempts to run the Process Lockbox program sites can reach out to the provider of the lockbox file to populate the batch number with a unique number for each file. With a unique batch number for each file this error should only appear when the lockbox file being imported is a duplicate.



Additional Information