503 An unexpected response has been reported by the Workflow Server

Description of Issue

Tyler Workflow Command Runner services will not start. 

Context
  • Time & Attendance
  • ExecuTime
  • Tyler Workflow service
Cause

The instance.twfapi application pool isn't running for the instance

Resolution
  1. Access IIS where Tyler Workflow is installed
    1. Right click on Windows Start → select Run
    2. Type inetmgr and press Enter
  2. With IIS open, on the left-hand side in the Connections Pane will be the name of the server.
  3. Select the arrow to the left of the server's name to open the IIS navigation tree.
    1. Start position, the arrow points to the right.
    2. After selecting the arrow, it will point downwards.
  4. Navigate to Application Pools
  5. Search for the Tyler Workflow instance in question
    1. Note: There will be several applications pools per instance of Tyler Workflow
  6. The name of the application pool that should be in a stopped state will be instancename.twfapi
    1. For example: train.twfapi
  7. Start the application pool
    1. Select the application pool in question.
    2. On the right, under the Actions pane, select Start
  8. Open up Services
    1. Select the Windows Start icon and type Services
    2. Press Enter
  9. Search for the Tyler Workflow Command Runner service in question and right click and select Start to confirm the service now starts successfully.
  10. Afterwards, restart the 3 Tyler Workflow services for the instance in question - How To Restart ExecuTime Tyler Workflow


Additional Information