Grant or restrict user permissions to override special conditions preventing payment

Description of Issue

The permissions to override special conditions preventing payment need to be granted or restricted for specific users. 

Context
  • Accounts Receivable
  • General Billing 
  • Property Tax Billing 
  • Community Development 
  • Utility Billing 
  • User Attributes (sprousrm) 
Cause

Certain users need to have the ability to override special conditions preventing payments and certain users need the ability restricted. 

Resolution
  1. These changes can only be made by a user with access to the User Attributes program, which can be found either by searching or using the following path: System Administration > Security > User Attributes
  2. Click Search. 
  3. Enter the User ID or Name of the user whose permissions need to be adjusted. 
  4. Click Accept.
  5. If multiple users return, use the arrows at the bottom of the screen to locate the correct user. 
  6. Click the Effective Permissions tab. 
  7. Click the filter button on the left underneath Filter active set. 
  8. Choose Revenue Systems from the Product dropdown. 
  9. Choose Accounts Receivable from the Module dropdown. 
  10. Click Go. 
  11. Scroll down through the filtered set until the Override special conditions preventing payment permission is found.  
  12. Click the Override special conditions preventing payment permission to view the permission detail. 
  13. The Value column indicates the user's current permission level. The options are:
    1. Yes: the user can override special conditions preventing payment. 
    2. No: the user cannot override special conditions preventing payment. 
  14. The Granted by column identifies which role or roles grants the permission. By default, the user has the most expansive permissions granted by any of their assigned roles and if any of the assigned roles grant permission, the user has the permission. 
  15. The user's permissions can be modified in any of the following ways depending on what best fits the use and need:
    1. If the permission is granted by a role that the user does not need, then the role can be deleted from the user using the steps outlined here: Remove role from munis user
    2. If the user does not have a role that should grant them this permission, then a role can be added to the user using the steps outlined here: Add Role to Munis User
    3. If the user has a role that should govern this permission, then the role can be edited using the steps below: 
      1. Click the Roles tab. 
      2. Select the role identified with steps 1-13. 
      3. The role should now be highlighted. Click Edit Role. 
      4. The Accounts Receivable Roles should open because of the filter entered earlier. If it does not, click the Accounts Receivable folder. 
      5. Click Update. 
      6. Check the box to Override special condition preventing payment to grant this permission or un-check the box to restrict this permission. 
      7. Click Accept. 
    4. Please note that editing the role will change the permissions for all users who are assigned to that role. To see all users assigned to a role, please see: List of users assigned a specific role
  16. The user will need to sign out and back in for the change in their permissions to take affect. 
Additional Information

If additional assistance is required, please contact the appropriate support team based on the Accounts Receivable (AR) category of the payment.Â