Enterprise ERP Anywhere Cashier not connecting to Cashiering



Description of Issue

When clicking Pay in Anywhere Cashier from Enterprise ERP Tender Payment screen, you receive the message xxxxx Refused to connect.



Context
  • Enterprise ERP

  • EERP

  • Cashiering (web)

  • Anywhere Cashier



Cause

When receiving the error Refused to connect, it should also display a specific URL. The site referenced needs to be added as a trusted domain via Tyler Deploy.



Resolution

OnPrem clients with Tyler Deploy access and Deploy/Configure permissions:

  1. In Tyler Deploy, navigate to Product Configurations > Tyler Cashiering Server

  2. Expand Tyler Cashiering Server section

  3. Check off Show advanced

  4. Scroll down to IIS Info

  5. In the Whitelisted Trusted Domain(s) field, add the domain referenced in the error

    1. Ex: The error is tylertowncash.tylertech.com refused to connect

    2. Tyler Deploy variable would be: frame-ancestors https://*.tylertech.com

  6. Scroll up and click Save

  7. Click Go to Deployment

  8. Run Cashiering deployment with Force Redeployment checked off 

SaaS clients:

Please contact Tyler Systems Management Support or log a case via the Online Support Client Portal



Additional Information