Effective Date and Last Activity Date for payments made towards Payment Plan periods not due yet does not match Payment Entry batch effective date



Description of Issue

Payments on Payment Plan bills for periods not yet due have the wrong effective date



Context
  • Payment Plans

  • Munis

  • EERP

  • Payments



Cause

This occurs when customers make a payment towards a payment plan bill when the payment plan has no amount due now and clerks are presented with this message and select option 1.

How To Apply This Payment: This Payment Plan has no amount due now.

Do you want to:

(1) Apply entire amount to upcoming period(s)

(2) Prepay the next period and apply any remaining amount to principal

(3) Apply entire amount to principal



Resolution

This behavior is working as intended per development.

The Effective Date/Last Activity for payments made towards payment plan periods that are not due yet is expected to be the due date of the period that is being paid.

This is due to how interest is calculated during the payment process and is set to do this to allow for the full amount of interest that is due for that period.



Additional Information