500 Error when trying to make BridgePay payment



Description of Issue

When attempting to make a BridgePay payment in Munis Citizen Self Service, the browser shows 500 - Internal Server Error. This started occurring after enabling one-time payment tokens and/or changing BridgePay credentials in CSS Hosting. 



Context
  • Munis

  • Citizen Self Service (CSS)

  • BridgePay

  • CSS BridgePay payment 500 error



Cause

As part of the Purchase Token setting, the web server upon which CSS is hosted must reach out to the BridgePay server to obtain a token. The firewall rules are preventing outbound requests from the externally facing CSS web server.



Resolution

The firewall needs to be updated to allow outbound communications from the CSS web server to BridgePay

  • FQDN: bridgepaynetsecuretx.com

  • IP: 192.84.6.8

  • Port 433 and 80



Additional Information

Test the connection by browsing to the following URL on the externally facing web server:

https://www.bridgepaynetsecuretx.com/PaymentService/ActionService.svc

When connection successfully, it will say: You have created a service.