Searches by street name does not return any Real Estate records in Citizen Self Service





Description of Issue

When searching by the street name, no real estate records are returned.



Context
  • Munis

  • Citizen Self Service

  • Real Estate

  • Web Services

  • V11.3



Cause

Development added a subsequent screen to real estate searches for performance. If the CSS user does not have access to that web service that the new screen uses, no records are returned.



Resolution
  1. Navigate to System Admin > General Admin > Web Services

  2. Click the Private Services button on the right side of the screen

  3. Select the Service View tab

  4. Locate txwsbrow_getParcelsForSreet and click the webservice

  5. From the Users without privileges to the current private web service box, select Access

  6. From the list of records locate and select wsuser (self hosted) or XXXXweb (SaaS)

  7. Press the Add > button to move the username to Users with privileges to the current private web service box

  8. Select Accept

  9. Select the Return Button to go back to the webservices screen

  10. Select the Generate WSDLs button from the right side of the screen

  11. Select All Modules radial from the prompt

  12. Select Accept



Additional Information