Cannot View Attachment in the TCM HTML Viewer due to Alert - Could Not Parse Date Error





Description of Issue

When attempting to view an attachment in the TCM HTML Viewer, an error appears stating:

Alert - Could Not Parse Date xxxx



Context
  • Munis

  • Tyler Content Manager 

  • TCM

  • TCM HTML Viewer



Cause

The date field on the TCM attachment is not set to a numerical value and is instead set to a text value. For example, instead of 06/01/2021, the date field states JUNE 1st 2021. 



Resolution

Please login to the TCM Full Client with administrative rights and follow the below steps:

  1. Select the Documents tab > Document Search

  2. Click Filter to select the particular document type affected 

  3. Once the document has been found, double-click to open it in the Document Explorer panel 

  4. Adjust the Date field to reflect a numerical value 

  5. Click Save

  6. Launch the affected document from the TCM HTML Viewer again to verify it can be viewed without error. 

If the above steps were not successful or further assistance is needed, please contact TCM Support.



Additional Information