External Task fails to submit to EnerGov - Due to Request Type not being mapped to a Code Case

Description of Issue
  • External Task fails to submit to EnerGov/EPL due to the Request Type not being mapped to a Code Case 

  • Error in WindowService Log: Error submitting task to external system during task processing. System.ArgumentNullException: Value cannot be null. Parameter name: input

Context
  • Tyler 311 

  • Enterprise Service Requests 

  • ESR

  • EnerGov

  • Enterprise Permitting & Licensing

  • EPL

Cause

 311 Request Type needs to be mapped to an EnerGov Code Case 

Resolution
  1. Navigate to Administration > External Systems 

  2. Click the vertical ellipses for the EnerGov external system 

  3. Click Edit 

    1. Remove any unwanted mappings if they exist

  4. Click + button to add a new mapping 

  5. After you have completed the mapping close the external system window

  6. Click on the vertical ellipses for the EnerGov external system 

  7. Click Sync Data Entry Fields 

    1. The Sync Data Entry Fields process will create data entry fields in Tyler 311 based on the data entry fields on the mapped code case types. If fields that are required on the code case type are not completed in Tyler 311 then the creation of the code case will fail. The data entry field sync process happens in the background and may take several minutes.

Additional Information

Refer to Master Article - External Task fails to submit to EnerGov for other reasons as to why the External Tasks fails to submit to EnerGov

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