TCM - Tyler Content Manager Server Connection Warning Error HTTP Error 401

Description of Issue

Receiving an error when attempting to access TCM through Munis stating:

Tyler Content Manager Server Connection Warning
Tyler Content Manager web service call encountered:
HTTP Error 401 () Contact Administrator to check TCM Server responsiveness.
(This message will only be displayed once per Munis sessions)

Context
  • Munis

  • Enterprise ERP

  • EERP

  • Tyler Content Manager

  • TCM

  • Permissions 

Cause

The user ID receiving the error needs TCM permissions configured and/or the TCM permissions have not yet synced to the TCM Full Client. 

Resolution

Verify that the user ID is in a Munis role that links to a TCM MU_xxx security group:

  1. Tyler Menu 

  2. System Administration > Security > User Attributes > Search on affected user ID 

  3. Click on the Data Access tab 

  4. Scroll to the way bottom and double-click on TylerCM group access

  5. Under the User Access Detail tab, if you see one or more TCM MU_xxx groups, please follow step #2

  6. If you do not see any TCM MU_xxx groups under the User Access Detail tab, the user will need to have one of their Munis roles linked to one or more TCM MU_xxx security groups. Please contact TCM Support if you need assistance with this.

If the user is already in a Munis role that links to a TCM MU_xxx security group, please follow the below steps:

  1. Tyler Menu 

  2. System Administration > Security > User Attributes > Search on affected user ID 

  3. Under the Roles tab, click Update

  4. Click Accept in the ribbon

  5. Ask the user to test again.

If neither of the above steps were successful and the user is still receiving this error, please verify that the user ID has been synced to the TCM Full Client:

  1. Launch the TCM Full Client and sign in with administrative rights. If you are not familiar with how to access the TCM Full Client, please see these instructions: How to Access and Launch the TCM Full Client.

  2. Navigate to Administration > Security Manager > search for the affected User ID. If you do not see the User ID listed, please follow these steps: How to sync users and TCM Permissions from Munis to TCM.

If all users are receiving this error, the Master Password may need to be reset:

How to Reset Master Password and Rebuild TCM Caches

If the user is still seeing the HTTP Error 401() error after completing the steps above, please contact TCM Support for further assistance and provide the user ID affected as well as which environment the error is occurring in (Live, Test, Train, etc). 

Additional Information

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