/
Change default database for ODBC connection

Change default database for ODBC connection





Description of Issue

cannot see database(s) when configuring ODBC in dropdown

cant access database in ODBC settings.



Context
  • Crystal Reports

  • ODBC

  • Munis all versions

  • default database

  • Self-hosted, OnPrem Client



Cause

Default database is not setup for user login in SQL Server.



Resolution

In SSMS, default database of user's login must be changed.

  1. Connect to SSMS using the servername, servername will be found in site report

  2. Expand the Security Folder

  3. Expand the Logins Folder

  4. Find the username from the list of all logins

  5. Right Click on the username and click on Properties

  6. Click General Tab on the left

  7.  Under default database drop down menu, select MUNIS production database from the list

  8. Click OK


Reconfigure the ODBC connection using the same server name and now the train/test/live/prod databases should be available.



Additional Information
















Related content

Cannot See Database Listed When Setting Up ODBC or SSMS Connection
Cannot See Database Listed When Setting Up ODBC or SSMS Connection
More like this
Create ODBC connection for SaaS clients
Create ODBC connection for SaaS clients
More like this
Create ODBC connection for OnPrem clients
Create ODBC connection for OnPrem clients
More like this
Update Crystal report to use new ODBC connection SaaS
Update Crystal report to use new ODBC connection SaaS
More like this
Crystal Reports create ODBC connection in AWS
Crystal Reports create ODBC connection in AWS
More like this
Update Crystal Report to use new ODBC connection
Update Crystal Report to use new ODBC connection
More like this