Enterprise Forms Delivery Definition Carriage returns and variable data email formatting



Description of Issue

When setting up a ReadyForms Delivery Definition to email a form, there are a couple additional options besides plain text that can be used to adjust the formatting. 



Context
  • Munis

  • Enterprise Forms

  • ReadyForms

  • Token

  • Carriage return

  • New line

  • Email

  • Variable data



Cause

When trying to enter a new line ("carriage return") simply by pressing the ENTER key, the Delivery Definition step saves rather than entering a new line. There are also variable data fields available for use with the email formatting.



Resolution

How to perform a Carriage Return in the Email Body:

  1. Go to the ReadyForms Delivery Definitions Program (System Administration>Printer/Device Administration>ReadyForms>Delivery Definitions)

  2. Click Search and locate the form and Delivery Definition you're trying to modify the email formatting for

  3. Click the relevant Delivery Definition Step that pertains to emailing

  4. In the email Message section, press the keys SHIFT + ENTER to perform a carriage return


Variable data fields that can be pulled into the email subject/body:

  1. Go to the ReadyForms Delivery Definitions Program (System Administration>Printer/Device Administration>ReadyForms>Delivery Definitions)

  2. Click Search and locate the form and Delivery Definition you're trying to modify the email formatting for

  3. Click the relevant Delivery Definition Step that pertains to emailing

  4. At the top of the Actions section of the Delivery Definition page, there is a box title Email Tokens:

    1. Click Email Tokens to bring up the different fields that can be pulled into the form

    2. To use an email token, either click Copy Token and paste into your email setup, or manually enter the token (ie. [*MUN_CLIENT_NAME*] )