TCM Connectivity Issue for Hosted Munis Clients with Self Hosted TCM





Description of Issue

Users getting error messages when attempting to view attachments through Munis. "Alert A problem has occurred while retrieving the long viewer link. Please reload the viewer from the integrating application."  "Can't reach this page. Make sure the web address http://10.X.X.X:8092 is correct "



Context
  • Tyler Content Manager (TCM)

  • Munis

  • Self Hosted

  • SaaS Client

  • Connectivity



Cause

Self hosted clients have a specific local IP address that must be used in the Document Explorer URL in the TylerCM for Munis Settings in Munis, while the other settings must use the hosted IP (NAT) for the self hosted TCM server.



Resolution

In the Tyler Menu, go to System Administration > General Administration > TylerCM for Munis Settings

  1. Click on the Update button in the menu.

  2. Update the Document Explorer URL with the site's LOCAL IP address, not the NAT IP address for the self hosted TCM Server.

  3. Update the remaining lines with the NAT IP address for the self hosted TCM Server.

Once updated, click the green Accept button on the top left of the menu.

Complete the Master Password reset, Rebuild TCM Caches, and test the Munis user access to documents.




Additional Information

Contact the client's IT department for the local IP address of the self hosted TCM server if you do not have access to it.

Contact TSM Support for the NAT IP address for the self hosted TCM server if you do not have access to it.Â