Process Lockbox Slow Since Upgrade



Description of Issue

Cannot run Lockbox Processing in New Version

Lockbox does not process 



Context
  • Process Lockbox

  • NEW Lockbox Import

  • Payment Processing



Cause

In versions 2019.1+ users may find the Process Lockbox program is running significantly slower. 



Resolution

A new, more efficient lockbox program was created for the new version of MUNIS. The NEW Lockbox Import must be added via Menu Settings.

  1. Navigate to System Administration < General Administration < Menu Settings

  2. Navigate into the Payment Processing Menu. This can be done by double clicking each menu path, or by highlighting the choice and clicking Forward. The menu path is General Revenues > Payment Processing. 

  3. Click update to access the menu caption. Then hit accept to move to the menu fields. 

  4. Click on the caption of the last visible row and then tab until a new blank row appears.

  5. Set the Program Id to arpmtimp. The Caption is what shows on the Munis menu and can be set at each site’s discretion.

  6. Click accept and the new program will appear when the menu is refreshed. 

To add the new program user's Menu Security via Roles. 

  1. Navigate to System Administration > Security > User Attributes

  2. Search for the UserId of the user that processes lockbox imports

  3. Highlight relevant role

  4. Click Edit Role

  5. Click Menu Security

  6. Highlight General Revenues

  7. Click Forward

  8. Highlight Payment Processing

  9. Click Forward

  10. Highlight NEW Lockbox Import

  11. Click Edit

  12. Select options for Role Access and Menu Access.

  13. Repeat steps 2-12 for each relevant user. 



Additional Information

Please reach out to Support for more informationÂ