SaaS flip TRSB error when managing custom reports



Description of Issue

When trying to make changes or launch reports in TRS Builder after a flip to SaaS this error appears on the screen and in the SSRS logs: An error occurred within the report server database. This may be due to a connection failure, timeout or low disk condition within the database.



Context
  • SaaS

  • SSRS

  • Custom Reports

  • TRSB

  • Munis

  • Saas flip from On-Premise



Cause

This occurs when the reporting database and reportingtempDB database names are changed during SaaS flips when the database is migrated to hosted servers. 



Resolution

The reporting database names need to be switched back to the original On-Premise names.  Please contact TSM SaaS Support for assistance. 



Additional Information

There are references in the reporting databases to the original names. This cannot be changed without updating many records in the reporting database manually, so reverting the names is the best solution.