No Employee Accrual Record for Accrual

Description of Issue

When using Time Entry or entering time directly into a payroll, an error message is displayed for some employees: No Employee Accrual Record for Accrual 3

Context
  • Munis
  • Payroll
  • Time Entry
  • Payroll Earnings and Deductions
  • Pay Master
  • Accrual Table
Cause

Accrual Code 3 was created and setup to Add or Subtract on Impact Accruals tab of the Pay Master. A decision was made to no longer have this accrual available, as it was never used, and the accrual codes was deleted from the system.  When the accrual code was deleted and removed from the Employee Accruals program and Accrual Table program the Impact Accruals tab of the Pay Master was not set to 'No Impact' but had the Add and/or Subtract still set for the pay code.

Resolution
  1. In the Accruals table program (Payroll>Payroll Setup >Accrual Tables), click Add to re-enter the Accrual code back into the system 
  2. Go to Pay Master (Human Resources/Payroll>Payroll>Payroll Setup>Pay Master)
  3. Search for all pay codes
  4. Click the Impact Accruals Tab and identify which pay codes have something other than No Impact set for the accrual code added in step 1
  5. Click Update
  6. Select No Impact from the drop-down for the Impact on the Accrual Type 
  7. Click Accept to save the changes
  8. Repeat steps 6 and 7 for all pay codes identified in step 4
  9. In the Accrual Tables program, Delete the accrual code/table added in step 1
Additional Information

If you are not experiencing this issue, but have the same error, additional information is available here in article Error - No Employee Accrual Record for Accrual 2 - when adding a pay type in Earnings and Deductions