ESS Benefit Enrollment shows a zero dollar for Employer Amount

Description of Issue
  • We have a Life Insurance for employees that is fully paid by the employer, but on ESS it show $0, why?
Context
  • Munis
  • Human Capital Management (HCM)
  • Employee Self Service (ESS)
  • Benefits Enrollment
Cause
  • The Enrollment Choice record is setup with a 0.00 value in the Employer Amount field
  • The option Calculate Cost is enabled
Resolution
  1. Navigate to the program Campaign Manager
    • Menu > Human Capital Management > Benefits Administration > Benefits Enrollment > Campaign Manager
  2. Click Search and locate the issue campaign
  3. Select the folder for Choices
  4. Click Search and locate the issue Enrollment Choice record
  5. Review for the fields Employer Amount and Calculate Cost
    1. The field Employer Amount should have the per-paid-period Employer Amount
    2. The option Calculate Cost should only be used in scenarios where the cost is calculated based on a Life Table
  6. Select Update and adjust as necessary
  7. Please note, any changes to the benefit enrollment setup will need to be generated in to update ESS
Additional Information

Please reach out to Munis Human Resources Support with any additional questions