Employees who changed positions are getting Access Denied message in ESS Time Punch In Out

Description of Issue

Two employees were moved to new Job Classes, and since then when they try to access the Punch In/Out in ESS, it takes them to a page that says Access Denied

Context
  • Employee Self Service
  • Time Punch
  • Time Card
Cause

After duplicating their prior Job Class's Base Pay to set the end dates in Employee Job Salary, the Primary Job/Position was left checked, which was causing the Punch In/Out function to think they should not have access based on the End Dates.

Resolution
  1. Navigate to the program Employee Job/Salary.
    • Menu > Human Capital Management > Payroll > Employee Maintenance > Employee Job/Salary
  2. Click Search and locate the issue job/salary record.
  3. Review for the field Primary Job/Position.
  4. Click Update and uncheck the flag for Primary Job/Position.
Additional Information

We suggest during the steps of duplicating the prior Job/Salary base pay record, the Primary Job/Position should be unchecked if it is no longer their primary.

Please reach out to Human Resources Support with any follow up questions.