How to tell if an unposted General Billing Invoice has been generated

Description of Issue

Need to know how to determine if a General Billing Invoice has been generated. 

Context
  • General Billing
  • Invoice Entry and Proof (gbinvent) 
  • Invoice Inquiry (gbinvinq) 
  • Bill Inquiry (arbilinq)
Cause

A way to tell if an unposted invoice in Invoice Entry and Proof has been generated is needed. 

Resolution
  • In Invoice Entry and Proof, if the Update and Delete buttons are missing in the top ribbon when viewing the invoice's Proof Header screen, then the invoice has been generated. 
  • In Invoice Inquiry, if the Folder next to Invoice is lit and links to the invoice in Bill Inquiry, then the invoice has been generated. 
  • In Bill Inquiry, if the invoice exists, then the invoice has been generated. 
Additional Information
  • The Generate button in Invoice Entry and Proof creates a record for the invoice in Bill Inquiry so that the invoice can be paid. Once generated, an unposted invoice cannot be deleted or updated and must be posted. Support recommends posting the batch of invoices whenever possible instead of using the Generate option to avoid any confusion. 
  • Additional resources for working in Invoice Entry and Proof can be found here: Master Article - Invoice Entry and Proof