Error printing Payroll Advices-Email option EmployeeEmail is empty-no email address in Employee Master

Description of Issue

When printing Payroll Advices, user is receiving errors for a few employees in the warrant: 

Email option EmployeeEmail is empty

User was able to hit Continue and print Payroll Advices as normal.

Context
  • Payroll Processing

  • ReadyForms

  • Employee Master

Cause

In Employee Master, several employees are listed with an Advice Delivery option of Primary Email Only under the Payroll tab, but do not have a primary email defined under the Address tab. The employee can be updated with either a Primary Email address or a different Advice Delivery option.

Resolution
  1. Navigate to Payroll>Employee Maintenance>Employee Master.

  2. Search for Employee and click Accept. 

  3. Click Update.

    1. Enter Primary Email under Address tab.

    2. Update Advice Delivery to another option not requiring a Primary Email address.

  4. Click Accept. 

Additional Information