Lockbox Program not Paying Existing Bill on Account





Description of Issue

Lockbox program not paying outstanding bill

Can the lockbox program pay oldest bill on account



Context
  • Munis

  • General Revenues

  • Accounts Receivable

  • General Billing

  • Process Lockbox File



Cause

In this scenario a site might identify that a Lockbox Payment file might be ignoring an older outstanding bill on a Customers Account. This is because the Process Lockbox program for General Billing Invoices is instructed to pay the Year, Category and Bill Number designated in the Lockbox file. Other Categories in Munis has logic to look at the Customers Account before applying to the bill in the file, unfortunately this is not true for Category 01 - General Billing Invoices. 



Resolution

Support recommends to investigate how the file is generated for the Lockbox Processing program. How are the Customer Accounts reported to the program or company to create the Lockbox file and why is the most recent bill being pulled from the account, should the file be delivering the older bill for payment first? Can that program or company update the file to look for existing outstanding bill before the most recent bill?



Additional Information