Grade Record Missing when Posting Action Entry

Description of Issue
  • An end user is unable to output post a personnel actions entry error. The error "Grade record missing" is displayed at the bottom of the screen
Context
  • Munis
  • Personnel Actions
  • Employee Job/Salary
Cause
  • The Grade and Step fields are blank when they should be defined with information based on setup in Job Class Master or Position Control
Resolution
  1. Navigate to the Personnel Action Entry program
    • Menu → Human Capital Management → Human Resources → Personnel Actions → Personnel Actions Entry
  2. Click Search and locate the issue employee record
  3. Click Detail to expand the record
  4. Select Employee Pay to review the Pending Job/Salary records
  5. Review each and every record that is indicated as a Base Pay
  6. Note the Job Class code and the Position Control code
  7. Review the programs Job Class Master and Position Control
    • Menu → Human Capital Management → Human Resources → Position Control → Position Control
    • Menu → Human Capital Management → Payroll → Payroll Setup → Job Class Master
  8. Review on each program the Salary Data tab to see if these records are setup with a Grade and Step records
  9. Assign the missing Grade or Step values to the Pending Job/Salary records
Additional Information
  • Please reach out to Munis Human Resources Support with any additional questions