Cashiering Requiring Some Users to Have Deposit Numbers, but Not Others

Description of Issue

Some Cashier's are prompted to insert a Deposit Reference for a batch, but some are able to take transactions successfully with no error. EERP and Cashiering settings are set to have this error enabled.

Context
  • Cashiering
  • EERP
Cause

A role in the EERP settings is conflicting and overriding the affected user.

Resolution

 The site will have to look through each EERP Role to determine which EERP user role is overriding the Cashiering Role:

  1. EERP Munis > System Administration > Security > User Attributes.
  2. Search.
  3. Enter User ID.
  4. Click on Effective Permissions tab.
  5. Scroll down to the Permission labeled Deposit numbers on payment batches and double click.
  6. Click Edit Role.
  7. Drill into Accounts Receivable folder.
  8. Click Update.
  9. Change Deposit numbers on payment batches to Always Required.
  10. Click Accept.
  11. Restart Cashiering client.
  12. Test.