Munis Scheduler Monitor Service Stops After Starting - Disable and Re-Enable Service

Description of Issue
  • When attempting to start the Munis scheduler the service stops immediately after starting. Attempting to start the service in the Windows Services program will present the following error: The Munis Scheduler Monitor service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs
  • The Munis Scheduler Monitor has been enabled in Tyler Deploy for the specific environment but it will not start even after updating the tylerservice password under Munis Scheduler Monitor Properties. 
  • The event viewer is showing this error about the scheduler: The configuration file (e:\munENV\utils\Config_munENV.xml) for this Munis Scheduler Monitor service does not exist. Please create a configuration file using the Munis Scheduler Monitor Management application.
Context
  • Munis Scheduler
  • Scheduler
  • Scheduler Engine
Cause

Issue with the Munis Scheduler Monitor service

Resolution
  1. Disable the scheduler from Tyler Deploy: 
    1. Navigate to Product Configurations > Munis ERP
    2. Select the applicable environment from the drop down
    3. Expand the section Munis ERP
    4. Scroll down to Enable Munis Scheduler Monitor
      1. If the box is checked, uncheck it
      2. If the box is already unchecked, leave it unchecked 
    5. Scroll back up and click Save
    6. Click Go to Deployment
    7. Click the Tasks tab
    8. From the dropdown, select Enable-Disable Scheduler Monitor Service
    9. Click Run
  2. Re-enable the scheduler: How to Enable Scheduler Monitor Service From Tyler Deploy
  3. On the server, return to Services > Munis Scheduler Monitor [env]
    1. If not running, right click on the service name and click Start
  4. After a few minutes, the Scheduler status should be Online in the Scheduler Queue in Enterprise ERP
    1. To update the status in the Scheduler Queue select View > Refresh
Additional Information
  • Run the following SQL query against an environment to obtain the current status
    • SELECT skec_engine, skec_mode_current FROM skedecfg
  • Restart Scheduler OnPrem