Voiding Cashiering Transactions from Payments Admin

Description of Issue

We are looking to void transactions from within Payments Admin without having to log into Cashiering to do so while having it reflect correctly in Cashiering and EERP Munis.

Context
  • Payments

  • Payments Admin

  • Cashiering

  • EERP

  • Munis

Cause

Payments Admin can void transactions that originated in Cashiering and have it reflect as voided in Cashiering and EERP Munis.

Resolution

Payments Admin will have this functionality built in. If this is not functioning as desired:

  • Upgrade to Cashiering 2021.10.1.0 or higher, as this was implemented with this service pack.

  • Within Cashiering, test the connection to Payments under Administration > Settings > General Tab. Locate the Test Payments button to test the connection to Payments. Reach out to support should this fail.

  • In Payments Admin, the Transactional systems information needs to be populated. More information on both settings can be found here: Cashiering - Payments (Reconciliation) 

If the process is not working, or the concern is about why transactions that originated in Cashiering that are voided in Payments Admin aren't reflecting properly in Munis, see below. A void in Payments Admin sends the void back to its external system of origin. If Cashiering is not receiving the void, then neither will Munis.

Additional Information

Once a void is initiated in Payments Admin, the void will be created in Cashiering with the following rules:

  1. If the batch the original transaction was created it is still open, the void will be created there.

  2. If the batch the original transaction was created in is closed, the void will be created in the original user's existing open batch.

  3. If the batch is closed and the user has no open batch, the void will create a new batch for it to be placed in.