Cashiering and OpenEdge Integration An Error Occurred Adding a Tender Invalid Field Format XWEBAUTHKEY

Description of Issue

In the Cashiering application, when trying to take a credit card payment with OpenEdge / EdgeExpress, you receive the following message: 

An error occurred adding a tender:

Invalid Field Format: XWEBAUTHKEY

There are no errors in the Cashiering application logs or the Hardware Console logs

Context
  • Cashiering

  • OpenEdge

  • EdgeExpress

  • Credit Card Processor

Cause

Credit Card processor Authentication Key value is incorrect

Resolution
  1. Contact OpenEdge to obtain correct authentication token

  2. Log into Cashiering with an administrator account

  3. Navigate to Credit Card Processors > click the pencil icon for the applicable processor

  4. Update Authentication Key field to correct token value

  5. Click Save

  6. Test a transaction with credit card payment

Additional Information

Â