Cashiering and OpenEdge Integration An Error Occurred Adding a Tender Invalid Field Format XWEBAUTHKEY
Description of Issue
In the Cashiering application, when trying to take a credit card payment with OpenEdge / EdgeExpress, you receive the following message:
An error occurred adding a tender:
Invalid Field Format: XWEBAUTHKEY
There are no errors in the Cashiering application logs or the Hardware Console logs
Context
Cashiering
OpenEdge
EdgeExpress
Credit Card Processor
Cause
Credit Card processor Authentication Key value is incorrect
Resolution
Contact OpenEdge to obtain correct authentication token
Log into Cashiering with an administrator account
Navigate to Credit Card Processors > click the pencil icon for the applicable processor
Update Authentication Key field to correct token value
Click Save
Test a transaction with credit card payment
Additional Information
Â