Paid Tax Statement Showing Incorrect Due Dates

Description of Issue
  • A Paid Tax Statement or Statements are showing the incorrect Due Dates. 
  • The Due Dates on a Paid Tax Statement do not match Tax Year Settings. 


Context
  • Property Tax Billing
  • Paid Tax Statement 
  • Tax Statements (txtaxstm)
Cause

The Paid Tax Statement populates the Due Dates from the bills themselves, not from any other source. 

Resolution
  1. Navigate to the Bill Inquiry program either by searching or via the following path: General or Property Revenues > Payment Processing > Bill Inquiry
  2. Select the Category of the bill from the Tax Statement. 
  3. Enter the Year of the Bill from the Tax Statement.
  4. Enter the Bill Number from the Tax Statement. 
  5. Click Go.
  6. The Paid Tax Statement should show the same Due Dates listed for the bill that returns.
  7. If Due Date is not a visible field in Bill Inquiry, then verify that the User Preferences for Bill Inquiry Display include this field or update the Bill Inquiry Display User Preferences if necessary by following the steps outlined here: Update User Preferences to Show Additional Information in Bill Inquiry and Payment Entry
Additional Information