Verify Credentials Step Failing in Tyler Deploy



Description of Issue

Error 1: The Verify Credentials step of Tyler Deploy Fails; logs may report invalid SQL server or invalid credentials.  Error message may look like:  Invalid admin login credentials for 'sqlaccount!' Exception calling Open with 0 argument(s): Login failed for user 'sqlaccount'.

or

Error 2: SQL instance XXXX\TYLERCI could not be found Exception calling "Open" with "0" argument(s): "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)"

Error 3: Invalid admin login credentials for sqlaccount!     
Exception calling "Open" with "0" argument(s): "Instance failure."



Context
  • Tyler Deploy

  • Product Deployment

  • Windows Defender Firewall

  • Account Credentials

  • SQL Server

  • On-Prem Servers



Cause
  1. Invalid SQL Server credentials are saved in Tyler Deploy, or sql account is locked out

  2. Traffic is potentially being blocked between database and application server



Resolution
  • Error 1: Verify the sql account password and name is correct, there are no spaces before or ahead of the password in the Tyler Deploy variable field.

    • Verify the user failing to login is not locked out within sql

  • Error 2 and 3: Review Enterprise ERP Port and Firewall RequirementsCTRL + F and search for keyword sql and verify each rule is in place on each server. 

    • Restart the SQL Browser Service on SQL server > Rerun Deployment. 

Contact Tyler Systems Management Support or log a case via the Online Support Client Portal for additional support. 



Additional Information