Master Article - Tyler Cashiering Hardware Issues
Description of Issue
This article is a collection of Tyler Cashiering resources to aid in troubleshooting hardware issues.
Context
- Tyler Cashiering (TC)
- Hardware Console
- Hardware Drivers
- EPSON
- Honeywell
- Cash Drawer
- Credit Card Reader
- Hardware Matrix
Cause
Hardware issues may be the result of incomplete installation of drivers, order of installation, permissions on the workstation, or other.
Resolution
Hardware Console and Client
- How to Install Cashiering Hardware Console
- How to Uninstall Cashiering Client or Hardware Console
- Need Cashiering Installation File for Workstation
- Hardware Console Button Greyed Out in Tyler Cashiering
- Tyler Cashiering Hardware Console Icon Not Present in System Tray
- How to Restart Cashiering Hardware Console
Printers
- Error Initializing Epson TM-S9000 in Hardware Console
- How to Update Epson TM-S9000 Receipt Printer in Hardware Console
- How to Update Epson TM-6000V Receipt Printer in Hardware Console
Other
Additional Information
Troubleshooting questions
- Has this ever worked?
- When did the issue begin?
- When did it last work?
- What changed in-between?
- Does this affect all workstations and/or users?
Epson Printers/MICR
- As of versions 2019.1.12+, 2019.3.6.0+, and 2020.1.3.1+ the Cashiering Client and/or Hardware Console installer no longer includes the device drivers and they must be installed separately.
- Has the printer worked previously?
- If no changes were made (upgrades, new workstation installs, etc.) and it stopped working suddenly, it is likely an issue with the printer itself.
- If it's never worked on the workstation, it likely is a driver issue
- If Cashiering was recently upgraded or devices haven't worked since upgrading, check device drivers
- At least after v2019.1.12 and 2019.3.6, you typically do not need to uninstall the Cashiering client and Hardware Console if you can narrow down the issue is related to device drivers.
- Supported device drivers rarely change. Once the right device drivers are installed, they shouldn't need to be updated unless the new devices are being added
- When the USB receipt printer is plugged into the workstation, it will show up in Control Panel > Devices and Printers under Unspecified
Hardware Console
- v2018: Hardware configuration is part of the client
- v2019.1 and 2019.3: Hardware Console is separate from the desktop client
- v2020+: Hardware Console is installed on workstation, client is web based
- HardwareService.exe needs to be running (May be named different depending on the version)
- When running, Hardware Console will be in the system tray
- Launch Tyler.Cashiering.HardwareService.exe from installation path.
- Ex: C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering\HardwareConsole
- Users need modify permissions to the Hardware Console folder for certain features to work properly such as the MICR
- See How to Install Cashiering Hardware Console for steps
- If the Cashiering client give errors communicating with the Hardware Console, what exactly triggers the error?
- Ex: printing receipts, check validation, credit card payments, cash payments, etc.
- Hardware Console has it's own logs separate from Cashiering application logs
- Can be accessed in the Hardware Console or from the Hardware Console folder
- Ex: C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering\Hardware Console\Logs
- Can be accessed in the Hardware Console or from the Hardware Console folder
- Verify Hardware Console version matches Cashiering version
- Version number found in top right hand corner of Hardware Console
- Hardware Console can be launched from the system tray
- On the bottom right corner of desktop, click the arrow to show hidden items
- Right click the Hardware Console icon > click Tyler Cashiering Hardware Console
- If version number does not match, uninstall incorrect version and install correct version.
Issues after upgrading
- Check for leftover Cashiering installations in Control Panel > Programs > Programs and Features or Apps & Features
- Check for leftover folders in C:\Program Files (x86)\Tyler Technologies
- If old versions were leftover, uninstall all versions and reinstall correct version
Different version's installers have different default installation paths
- 2017, 2018, up to 2019.1.11, up to 2019.3.5
- C:\Program Files (x86)\Tyler Technologies\Cashiering
- 2019.1.12+, 2019.3.6+, 2020.1+
- C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering
- 2021.1.11+, 2021.6.0+
- C:\Program Files (x86)\Tyler Technologies\Cashiering (Web)