How to Install Cashiering Hardware Console

Description of Issue

How to install Cashiering Hardware Console

Context
  • Cashiering 2020.1+

  • Hardware Console

Cause

Cashiering Hardware Console for version 2020.1+ needs to be installed.

Resolution
  • These steps are specific to Cashiering 2020.1+

  • If installing the Cashiering Client/Hardware Console for 2019.1/2019.3, please see Install Cashiering Client for 2019.1.12 and Higher and 2019.3.6 and Higher

  • In order to use peripheral devices with the Cashiering Hardware Console, supported device drivers must be installed. 

    • The Hardware Console installer does not include the device drivers and they must be installed separately: Cashiering Hardware Drivers

    • If device drivers are installed after the Hardware Console, restart Hardware Console driver install is complete.

    • If device drivers have already been installed, they typically should not need to be reinstalled. 

  1.  Uninstall previous versions if applicable. Leftover installation files from previous versions can cause hardware conflicts

    1. How to Uninstall Cashiering Client or Hardware Console

  2. For the 2020.1+ releases, the Hardware Console installer can be downloaded from the Cashiering UI.Web page

    1. Launch Cashiering UI.Web URL and log in

    2. In the top right corner, click the 9-box menu

    3. Click Hardware Console Installer to download the Tyler.Cashiering.HardwareConsole.msi 

  3. Double click Tyler.Cashiering.HardwareConsole.msi to run the installer

    1. On the Welcome page, click Next

    2. The wizard will suggest a destination folder. If you would like a different location, click Change and select the desired location

    3. Once the location has been selected, click Next

    4. Enter the UI.Web URL and click Next

      1. How to find the URL for Cashiering

      2. If the URL is correct but you get Unable to successfully access the Cashiering UI.Web URL. Please verify the URL, keep the URL filled out and check off Skip URL Validation, then click Next

    5. Click Install

    6. Once the installation is complete, click Finish

      1. If the installation fails with the error Hardware Console Setup Wizard Ended Prematurely, please see Hardware Console Setup Wizard Ended Prematurely

  4. PRIOR TO VERSION 2021.10.1.0: The user MUST have Modify permissions to the Hardware Console folder

    1. Navigate to Cashiering directory

      1. Ex: C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering

    2. Right click on the Hardware Console folder

    3. Click Properties

    4. Click the Security tab

    5. Click Edit

    6. Click on Users (may be Authenticated Users) to see what permissions that group has

    7. Under the Allow column, check off Modify

    8. Click OK

    9. Click OK

    10. After granting Modify permissions, restart the Hardware Console


2021.6.0.0/2021.1.11.0 Changes

NOTE: For the 2021.6.0.0/2021.1.11.0 and higher releases, the Hardware Console can be installed alongside the 2019.1/2019.3 Hardware Console and WPF Cashiering client. Below is a summary of the installer changes:

  1. Changed the installer name listed under Apps & Features to Cashiering Hardware Console (Web)

    1. The original name is Tyler Cashiering Hardware Console

  2. The shortcut and system tray hover text displays Cashiering Hardware Console (Web)

    1. The shortcut and system tray hover text for 2019.1/2019.3 is Tyler Cashiering Hardware Console

  3. Installing the files by default to C:\Program Files (x86)\Tyler Technologies\Cashiering (Web)

    1. The original install location was C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering

    2. The other installers (2019.1/2019.3) will continue to install the files to C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering

  4. Changed the port that is used to 48099

    1. Previously the port 48098 was used

    2. The other installers (2019.1/2019.3) will continue to use 48098

  5. Will uninstall the original Hardware Console software for 2020.1 and higher releases

    1. Will only support side-by-side installations for 2019.1 and 2019.3 that use the WPF program

  6. When using the Hardware Console, only one version at a time should be started and used with a particular Cashiering version

    1. When a different version is being tested, only that version's Hardware Console should be started and used

    2. Fully exit the Hardware Console from the browser and system tray before starting the Hardware Console for a different version

    3. Note: The Hardware Console may automatically start when the workstation is turned on. Check the system tray and exit the Hardware Console for the version not in use.

Additional Information