Installing Epson TM-H6000V Receipt Printer for Cashiering
Description of Issue
How do I install the Epson TM-H6000V receipt printer to work with Cashiering?
Context
- Cashiering
- Printer
- Receipt Printer
- Epson 6000V
Cause
The Epson TM-H6000V requires OPOS 3.0.0, unlike the TM-H6000ii, iii, and iv which leverage OPOS 2.70. OPOS 3.0.0 needs to be installed manually.
Resolution
- These steps are specific to the Epson TM-H6000V model
- For the Epson TM-H6000 ii, iii, and iv models, please see Installing Epson TM-H6000 ii iii or iv Receipt Printer for Cashiering
It is assumed that the printer is ready to go before installing drivers (paper loaded, print cartridge installed, etc.)
You must have administrator rights to install drivers
Install EPSON OPOS Software
- Obtain the Cashiering Hardware Drivers
- Navigate to ManualHardwareDriversV3 > OPOS3.0.0
- Double-click EPSON_OPOS_ADK_V3.00ER2.exe
- EPSON OPOS ADK Setup will open. Click Install
- Click Next
- Accept the terms of the License Agreement and click Next
- On the Custom Setup page click Next
- Click Install
- Click Finish and Close
OPOS Setup
- Power on printer, then connect USB to workstation
- From the Windows Start menu, navigate to the EPSON OPOS ADK folder, right click SetupPOS and select Run as Administrator
- Also located at C:\Program Files (x86)\OPOS\Epson3\SetupPOS
- In the EPSON OPOS ADK program, click the plus next to Device to expand
- Right-click POSPrinter > Add New Device
- In the Select Device Name box, select TM-H6000V and click Next
- Click CheckHealth Interactive
- Click Start to test for a Receipt
- When you see OPOS_SUCCESS in the Result field, click Close
- The SetupPOS result window will display. Click OK.
- Click Finish
If your device supports MICR:
- Expand Device, right click on MICR and select Add New Device
- Select TM-H6000V for device name
- Select TM-H6000V for detailed model. Click Next
- Click CheckHealth Interactive
- Insert a check in the MICR slot and click Start, then Read
- The check will be pulled through and the characters will be displayed on the screen
- Ignore the contradictory warning message and click OK
- If your device is connecting to a Cash Drawer: Installing APG Serial Cash Drawer for Cashiering
- Exit OPOS when done
Hardware Console
- How to Install Cashiering Hardware Console or Install Cashiering Client for 2019.1.12 and Higher and 2019.3.6 and Higher
- If Hardware Console is already installed, close and restart the Hardware Console
- Click the pencil and add the Epson TM-H6000V printer
- Click Save
- Click Re-initialize
- Click Logging to check for errors.
- If you see any errors initializing device, close the Hardware Console from the browser and exit from the system tray
- Launch Tyler.Cashiering.HardwareService.exe from installation path. Ex: C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering\HardwareConsole
- Open the Hardware Console from the system tray, or from the 9-Box menu in the UI.web web page
- Click Re-initialize and check Logging for errors or a success message
- Once the printer initializes successfully, add any additional devices such as MICR Reader and Cash Drawer.
- Launch Cashiering and have the end user test the device(s)
Additional Information
How to Restart Cashiering Hardware Console
- The printer will not initialize successfully if there are any errors with the printer. Please see Epson Receipt Printer LED Light Indicators for more information
- These articles contain initial troubleshooting steps that are useful for multiple device designations:
- How to Update Epson TM-6000V Receipt Printer in Hardware Console
- Error Initializing Epson TM-S9000 in Hardware Console
- Check for residual printer drivers in Programs & Features and delete if necessary.