How to Change User Name in Munis
Description of Issue
A user went through a name change or their username has changed for other reasons. Munis User Attributes needs to be updated to reflect the new username.Â
Context
- Munis
- System Admin
- SecurityÂ
- User Attributes
- Cloud Admin
Cause
User IDs cannot be edited after being added to Munis User Attributes. A new user needs to be created.
Resolution
PrerequisitesÂ
- SaaS Clients:
- Create new user in Cloud Admin with updated username - OR -Â
- Contact TSM SaaS Support to update the existing account in the Datacenter Active Directory domain
- OnPrem Clients:
- Update name and username in Active Directory or create a new Active Directory account
Create New User in Munis
- Log into Munis with an account that has System Administration access
- Open User Attributes (System Administration > Security > User Attributes)
- Create the new user manually, or by using the LDAP Sync tool
- Use Move User History to copy history from the old username to the new username: Move User History in Munis
- When ready to release the new account for use, on the toolbar click Update to change user account status from Disabled to Enabled
- On the old account, change user account status from Enabled to Disabled
- SaaS Clients: Disable old user ID in both Munis and Cloud Admin
Additional Information