500 Internal server error when applying via Employment Opportunities page



Description of Issue
  • User tries to apply for a position via Employment Opportunities page

  • User receives 500 Internal Server error when entering login information from Employment Opportunities page



Context
  • ESS

  • Munis 

  • Job Openings

  • Self Service Applications



Cause

Special character is used in the Self Service Application Form field



Resolution

To verify, review Job Openings > Advertising Tab:

  1. Go to Munis> Human Capital Management> Recruiting> Job Openings

  2. Search the Job Opening

  3. Click on the Advertising Tab

  4. Review the Application field

    1. If the Application field includes a special character

      1. The Self Service Application Form Code will need to be updated

To update the Self Service Application Form field:

  1. Go to Munis> Human Capital Management> Recruiting> Self Service Applications

  2. Search for the Self Service Form that is attached to the Job Opening

  3. Duplicate the Self Service Application

  4. Remove the special character from the Self Service Form Code 

  5. Click Accept

  6. Delete the older Self Service Application



Additional Information

Please reach out to Munis Human Resources Support with any additional questions