Installing Epson TM-S9000 Receipt Printer for Cashiering



Description of Issue

How do I install the Epson TM-S9000 receipt printer to work with Cashiering?



Context
  • Cashiering

  • Printer

  • Receipt Printer

  • Epson 9000



Cause

In order to use the Epson TM-S9000 with the Cashiering Hardware Console, supported device drivers must be installed.



Resolution

Device drivers can be installed via the Tyler Cashiering Hardware Drivers.exe installer, or manually. For instructions on using the Tyler Cashiering Hardware Drivers.exe, please see Cashiering Hardware Drivers.


Manual Install of EPSON Drivers

  1. Obtain drivers: Cashiering Hardware Drivers

  2. Navigate to ManualHardwareDriversV3\EpsonS9000\TMS9000S2000DRV201\Setup

  3. Right click on Setup.exe > Run as Administrator

  4. Click Next at the welcome screen

  5. Accept the license agreement > click Next

  6. Accept the Default Installation Path and install the 32-bit driver > click Next

    1. Note: The 64-bit driver can be installed as well, but it not currently used by the Tyler Cashiering software. This can be unchecked.

  7. Review the installation confirmation screen > click Next

  8. The complete screen will appear with the results of the installation > click Finish

  9. Power on the printer, then plug into workstation


Hardware Console

  1. How to Install Cashiering Hardware Console or Install Cashiering Client for 2019.1.12 and Higher and 2019.3.6 and Higher

    1. If Hardware Console is already installed, close and restart the Hardware Console

  2. Open the Hardware Console from the system tray, or from the 9-Box menu in the UI.web web page

  3. Click the pencil and add the Epson TM-S9000 printer

  4. Click Save

  5. Click Re-initialize

  6. Click Logging to check for errors.

    1. If you see any errors initializing device, close and restart the Hardware Console

    2. Click Re-initialize and check Logging for errors or a success message

  7. Once the printer initializes successfully, add any additional devices such as MICR Reader and Cash Drawer.

  8. Launch Cashiering and have the end user test the device(s)



Additional Information

To Close and Restart the Hardware Console:

  1. Exit Hardware Console from browser

  2. Exit Hardware Console from system tray

    1. On the bottom right corner of desktop, click the arrow to show hidden items

    2. Right click the Hardware Console icon > click Exit

  3. Launch Tyler.Cashiering.HardwareService.exe from installation path. Ex: C:\Program Files (x86)\Tyler Technologies\Tyler Cashiering\HardwareConsole

  4. Open the Hardware Console from the system tray, or from the 9-Box menu in the UI.web web page


The printer will not initialize successfully if there are any errors with the printer. Please see Epson Receipt Printer LED Light Indicators for more information.

Error Initializing Epson TM-S9000 in Hardware Console