Installing Epson TM-H6000 ii iii or iv Receipt Printer for Cashiering

Description of Issue

How to install and configure an Epson TM-H6000 series printer (ii, iii, or iv as opposed to the 6000v) to work with Cashiering.

Context
  • Epson TM-H6000ii
  • Epson TM-H6000iii
  • Epson TM-H6000iv
  • 6000 series
  • Cashiering
  • Tyler Cashiering
  • Hardware Console
Cause

Supported drivers need to be installed to use receipt printers with Cashiering. 

Resolution
  • The Epson TM-H6000 ii, iii, and iv models are compatible with both versions of OPOS. Either OPOS 2.70 or OPOS 3.0 can be installed and used.
  • For the Epson TM-H6000V, please see Installing Epson TM-H6000V Receipt Printer for Cashiering
  • It is assumed that the printer is ready to go before installing drivers (paper loaded, print cartridge installed, etc.)

  • Administrator rights are required to install drivers or make device changes in EPSON OPOS ADK


Install EPSON OPOS 2.70 Software

  1. Obtain the Cashiering Hardware Drivers
  2. Navigate to ManualHardwareDriversV3\EpsonADK\OPOSADK\ADK270ER18\Disk1
  3. Double-click setup.exe
  4. Choose your language and click OK
  5. Click Next at the welcome screen
  6. Accept the terms of the License Agreement, then click Next
  7. Select No registry file, then click Next
  8. Select User as the Setup Type, keep the default installation path, then click Next
  9. Review the installation settings, then click Next
  10. Select the appropriate port(s), usually Serial and USB, then click Next
  11. When the install completes, uncheck Display the release notes, then click Finish
  12. Close EPSON OPOS ADK when it opens

-OR-

Install EPSON OPOS 3.0 Software

  1. Obtain the Cashiering Hardware Drivers
  2. Navigate to ManualHardwareDriversV3 > OPOS3.0.0
  3. Double-click EPSON_OPOS_ADK_V3.00ER2.exe
  4. EPSON OPOS ADK Setup will open. Click Install
  5. Click Next
  6. Accept the terms of the License Agreement and click Next
  7. On the Custom Setup page click Next
  8. Click Install
  9. Click Finish and Close 


OPOS Setup

  1. Connect the power supply, then connect the USB cable from the printer to the computer
    1. NOTE: If the receipt printer has both a USB and 9-pin serial port, verify that the dip switches next to the USB port are both set to off.

  2. Power on the printer and allow Windows detection and automatic installation of hardware
  3. From the Windows Start menu, navigate to the EPSON OPOS ADK folder, right click SetupPOS and select Run as Administrator
  4. In the EPSON OPOS ADK program, click the plus next to Device to expand
  5. Right-click POSPrinter and select Add New Device
  6. Select the model of the device for device name (TM-H6000ii, iii, or iv). We will use the TM-H6000III in this example.
  7. Select the specific model for detailed model. This will probably be the same as the device name.
  8. Click Next
  9. Click CheckHealth Interactive
  10. Make sure receipt is selected, then click Start
  11. Check the printer for notification of a successful test
    1. Note: Paper must be manually fed a couple lines after printing to see the text
  12. If successful, you will see OPOS_SUCCESS in the Result field
  13. Click Close, then click Finish
  14. If your device supports MICR:

    1. Expand Device, right click on MICR and select Add New Device
    2. Select TM-H6000III for device name
    3. Select TM-H6000III for detailed model. Click Next
    4. Click CheckHealth Interactive
    5. Insert a check in the MICR slot and click Start, then Read
      1. The check will be pulled through and the characters will be displayed on the screen
    6. Ignore the contradictory warning message and click OK
  15. If your device is connecting to a Cash Drawer: Installing APG Serial Cash Drawer for Cashiering
  16. Exit OPOS when done

Hardware Console

  1. How to Install Cashiering Hardware Console or Install Cashiering Client for 2019.1.12 and Higher and 2019.3.6 and Higher
    1. If Hardware Console is already installed, close and restart the Hardware Console
    2. Please note: Users group MUST have Modify permissions to the Hardware Console folder
  2. Click the pencil and add the Epson TM-H6000 printer
  3. Click Save
  4. Click Re-initialize
  5. Click Logging to check for errors
  6. If you see any errors initializing device, restart the Hardware Console
  7. Open the Hardware Console from the system tray, or from the 9-Box menu in the UI.web web page
  8. Click Re-initialize and check Logging for errors or a success message
  9. Once the printer initializes successfully, add any additional devices such as MICR Reader and Cash Drawer
  10. Launch Cashiering and have the end user test the device(s)
Additional Information

How to Restart Cashiering Hardware Console