TCM server connection warning - Connection Failed


Description of Issue

TCM server connection warning - Connection Failed

Context
  • TCM
  • Apache
  • Munis ERP
Cause

This occurs when connections to TCM has encountered asynchronous connection failure, which could be multiple issues with the services.

Resolution
  1. Sign in to the TCM server with the tylerservice account or equivalent.
  2. Open services.msc to ensure that Apache is running
  3. Check the task manager to see if Apache services are using a high amount of CPU or memory, services may need to be restarted.
  4. Restart Apache services for that environment: Restarting Apache Tomcat Services
  5. Check that the Document Viewer URL and the Base Web Service URL in Munis are using the same port that is configured in Tyler Deploy → Product Configuration → Tyler Content Manager → Tyler Content Manager → Tomcat - HTTPS → Port
  6. Verify Apache is back up and running by checking the TCM URL and opening the full client or open Munis and go to System Administration> General Administration > TylerCM settings for Munis.  If the version is showing then it is connected, if it is showing unknown after an Apache restart, reach out to TSM Support.
Additional Information

If connection is still failing call TSM Support.