Cashiering failed to generate reprint receipt

Description of Issue

When trying to reprint a receipt in Cashiering, you get the following error: An Unknown error has occurred while generating the reprint receipt

Error: Failed to generate reprint receipt 

Virtual-tape-transaction - genererateReprintReceipt - failed to generate reprint receipt with the following error: Error Code: 500 Message: Http failure response for https://xxxx/prod/cashiering/ui.web/Receipt/GenerateReprintReceipt:500 OK 

Context
  • Cashiering Hardware Console
  • Epson TM-S9000U
  • Tyler Cashiering
  • Printer Receipts 
Cause

The Epson TM-S9000U is not able to properly connect to the Hardware Console. This could be caused by incorrect drivers, or an issue with the printer such as low ink or paper.

Resolution
  1. Open the Hardware Console from the system tray, or from the 9-Box menu in the UI.web web page
  2. Click Re-initialize
  3. Click Logging to check for errors
    1. Error Initializing Epson TM-S9000 in Hardware Console
  4. Check control panel lights on printer
    • All orange lights must be addressed. If there are any error lights on the printer, it will not initialize successfully in the Hardware Console.
    • If ink light is orange, replace the ink: Changing Epson Receipt Printer Ink Cartridge
    • If paper light is orange, replace the paper
    • If the error light is orange, power cycle the device
      • Power down, unplug from workstation, unplug from power source for 10-15 seconds, plug back into power source, power on and let start up fully, plug into workstation
    • Epson Receipt Printer LED Light Indicators
Additional Information