Cashiering Receipt Printer Will Not Install on Windows 11 Workstation Epson TM-S9000



Description of Issue

When trying to install the drivers for the Epson TM-S9000MJ, possibly others, the device is not properly installed, shows a ! in Device Manager and a message about possibly corrupt drivers.



Context
  • Tyler Cashiering 2019+

  • Windows 11

  • Windows 10

  • Core Isolation

  • Memory Integrity



Cause

New security feature in Windows 10 and Windows 11 called Memory Integrity is enabled.



Resolution
  1. Check if Memory Isolation is enabled by following this Microsoft article, Device protection in Windows Security

  2. If Memory Isolation is enabled there are two solutions.

    1. Disable Memory Isolation or

    2. Update the Epson Driver to use a more recent driver

      1. Completely remove all Epson software and drivers following the steps in this article, Device Removal

      2. Obtain Manual Drivers download: Cashiering Hardware Drivers

      3. Install the Hardware Console

        1. Click Next at the welcome screen

        2. Accept the license agreement > click Next

        3. Accept the Default Installation Path and install the 32-bit driver > click Next

          1. Note: The 64-bit driver can be installed as well, but it not currently used by the Tyler Cashiering software. This can be unchecked.

        4. Review the installation confirmation screen > click Next

        5. The complete screen will appear with the results of the installation > click Finish

        6. Power on the printer, then plug into workstation

    3. Complete the Hardware Console installation

    4. Download the TMUSB v8.00 driver from Epson, Epson Driver v8.00. expand Drivers and download TMUSB Device Driver v8.00b

      1. Install the new diver from Epson using the setup file

      2. Verify that the printer is properly installed in Device Manager, no splats (warning) 

    5. Add device to Hardware Console

    6. Reboot computer

  3. Verify receipt printing and check scanning