Dynamsoft Version Conflict when direct scanning to Content Manager from HTML

Description of Issue

User(s) is no longer able to direct scan to Content Manager through the HTML browser in production after testing direct scanning in a non-production environment where Content Manager has been upgraded

Context
  • CM
  • Content Manager
  • Dynamsoft
  • HTML Browser 
  • EERP
  • Munis
Cause

Only one Dynamsoft driver can be installed at a time on a workstation, and that driver must be compatible with the version of CM being used
While testing in the upgraded, non-production environment a new dynamsoft driver was installed which is not backward compatible to the version that is installed to CM Production

Resolution

When a user is testing in a non-prod environment and has downloaded a newer driver, that driver will need to be un-installed prior to scanning in a production environment until all environments are upgraded to the same version
After the driver is removed, then next attempt to direct scan will prompt for the driver to be downloaded again, and that driver will be the one compatible to the current CM version 

Please review this article, which includes step on how to uninstall the driver:
Prompted for Dynamsoft service to be installed when scanning to TCM when it has already been installed

Note - IT may need to assist if user permissions are not authorized to install/remove software on the workstation