Delete Pending Will Not Complete



Description of Issue

In the Utilities program when user clicks on the Delete Pending button the process will show a loading screen and then return to the Utilities program without changing the records.



Context
  • Munis

  • UBCIS



Cause

The issue occurs with a very specific scenario when a service that was originally on the owner is no longer on the owner and was stopped on a prior customer so that when the revert to owner happened, it was never reactivated. The logic during the delete is finding that old service, seeing that it moved to a different customer, and for some reason preventing the delete even though it shouldn't be involved.



Resolution

Install MUN-466701 once work ticket is complete, or the relevant ticket to site's version of Munis.


As a workaround site may use the below steps:

1. Use the Delete Customer function to remove the pending customer and all their services

2. Update the old customer to reset their stop date to 12/31/9999

3. Use Reset Services and possibly Remove Final to reset the old customer's services back to active/stop date to 12/31/9999/clear the final flag.



Additional Information