TCM Open Search Update bin mapping failed

Description of Issue

Within the TCM full client error message states, "Open Search Update bin mapping failed, which may affect searching for documents. Contact support for assistance."

Context
  • Tyler Content Manager (TCM)

  • Open Search

  • Ports

  • Deploy

Cause

Open Search services on the TCM application server is showing stopped status. 

Resolution
  1. Remote Desktop into the TCM application server

  2. Open services

  3. Right-click on Open Search service and click Start

    1. Refresh services list and verify service shows Running, if not proceed with next steps below

  4. If Open Search service immediately shows stopped again verify the port assigned to the service is unique:

    1. Open command prompt as administrator

    2. Input command

      Get-NetTCPConnection -State Listen | where Localport -like XXXX

      1. XXXX=Port number

        1. If results populate with the service stopped this would indicate the port is not unique and another service is utilizing it

  5. Log into Deploy and navigate to the Tyler Content Manager configuration settings:

    1. Scroll down to Elastic Search and within the Port field provide a unique port number

    2. Scroll to the top of the page and click Save

    3. Redeploy TCM

Additional Information

Please create a case with TSM Support for further assistance in the Support Portal