Unable to edit case titles of some support cases

Description of Issue

I am a Super User for my organization and I noticed I can only edit the case titles of some support cases, but not all. Why would this be?

Context
  • Client Support
  • Online Support Incidents
Cause

Only the primary contact of a case may update the title.

Resolution

There is no functionality or plans to adjust how this currently works.

Additional Information

Have more questions on the Online Support Incidents portal? Check out the Master Article - Online Support Incidents for more information!