There is no valid position record as of the to date for the entered job and position-Time Entry-Position Control



Description of Issue

While entering an Employee record in Time Entry, user receives the following error:

There is no valid position record as of the 'To' date for the entered job and position. 

There are current and active Job/Salary records for the employee for that Job Class and Position Control combination.



Context
  • Payroll

  • Earnings and Deductions

  • Time Entry

  • Employee Job/Salary

  • Position Control



Cause

The Job Class attached to the Position Control record is different than the Job Class assigned to the pay records in Employee Job/Salary



Resolution
  • Update Position Control with the correct Job Class code

  • Create new Employee Job/Salary records for the employee with either a new Position Control record or with the Job Class that is attached to Position Control. Employee Master will also need to be updated. 

It is recommended that any updates be made in test or train first before making changes in Live and proceeding with payroll. 



Additional Information