Error inserting into errlog table message in Payment Batch Reversal

Description of Issue

When running the select step of the Payment Batch Reversal process users receive Error inserting into errlog table error and using List Errors in Payment Batch Reversal does not indicate which receipt(s) are causing the issue.

Context

Munis 

Utility Billing

Payment Batch Reversal

versions 2018+

Cause

Error is caused by any receipt in the batch that cannot be reversed due the reversal of that receipt causing one or more installments or lines on the Bill to have a paid balance that is less than zero.

This error is due to a transaction that has occurred after the payment was made and that transaction moving the payment or portion of that payment off of the original bill being paid.

Resolution

Install work ticket corresponding to Munis version - this work ticket addresses the issue with the error appearing and the issue with Munis not generating an error report of the receipts causing the error to occur.

MUN-406885 (2018.1.29.0)
MUN-406886 (2019.1.21.0)
MUN-406887 (2019.1.22.0)
MUN-406888 (2019.3.17.0)
MUN-406889 (2020.3.0.0A)
MUN-389196 (2021.2.0.0)
MUN-406896 (2022.2.0.0)

Work around until corresponding work ticket is available - Contact support for assistance in determining which receipts are causing the error.

Additional Information