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CM security group restricting user access to certain attachments

CM security group restricting user access to certain attachments





Description of Issue

User is not allowed to view a particular document type, yet it appears they should have access through their current roles and CM security groups.



Context
  • Enterprise Resource Planning

  • EERP

  • Content Manager

  • CM

  • Permissions



Cause

A user may appear to have access to a particular document type, but they still cannot see the corresponding attachments. It is possible that they have been added to a role associated with a security group with less access that is ultimately limiting the user's access.



Resolution
  1. Identify the document type that the user cannot access attachments under.

  2. Log into the CM Full Client as an admin user.

  3. Click on Administration.

  4. Click on Security Manager.

  5. Find the user that cannot access the attachment and highlight their Name/ID.

  6. Above and to the right, click on Show Effective Rights (padlock symbol).

  7. In the bottom Document Effective Rights section, find the document type that the user could not access. Take note of what their access is.

    1. NOTE: If the user has the correct permissions, then this may be another issue. Please contact CM Support if this is the case. If less rights are there than expected, see step 8.

  8. In the top All Effective Rights section, scroll down to find the document type again. In the Group column, this will tell you what security group is limiting the user's access.

  9. Do not make permission changes in the CM Full Client.
    Instead, go into Munis > Tyler Menu > System Administration > Security > User Attributes. 

  10. Find the user whose permissions you would like to change. 

  11. Click on the Data Access tab.

  12. Scroll down until you find TylerCM group access under the Category column. Double-click on it.

  13. Find the Group ID you found in the CM Full Client that was restricting access. Under the Granted By column you will find the role that it is associated with.

  14. Either go to the Roles program or click on Edit Role below.

  15. You can either remove the user from the role, or make a change to the role such as removing the security group that was restricting access.

    1. NOTE: This change will affect every user in the role.

  16. Once completed, have the user test.



Additional Information












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