Error adding employee in Time Entry - Invalid Employee Number

Description of Issue

I am trying to add an employee into Time Entry and am getting an error saying the employee is invalid but I have checked all their data and everything is active and has good dates. 

Invalid Employee number: XXXXXX

Context
  • Munis
  • Time Entry
  • Employee Job/Salary
  • Roles
Cause
  • On the user's Role, the Access non-subordinates checkbox was unchecked 
  • In Employee Job/Salary, the employee did not have a base pay checked as Primary Job/Position. 
Resolution
  1. Go to Roles (System Administration>Security>Roles)
  2. Search for the user's Role. Click the HR Management/Payroll folder.
  3. Click the Time Entry tab. Click Update. Check the box for Access non-subordinates. 
  4. Go to Employee Job/Salary. (Payroll>Employee Maintenance>Employee Job/Salary)
  5. Search for the employee. Click Update. Check the Primary Job/Position checkbox on their applicable base pay record. Click Accept. 
Additional Information