401 Message Exporting ReadyForms Template

Description of Issue

When attempting to export a standard ReadyForms template for previewing, it throws a 401 error in the top right corner. 

An F12 trace returns a 401 error.

Clicking the link in the 401 error presents the following: 

"error":{

"code":"","message":"Authorization has been denied for this request."

Context
  • ReadyForms Administration
  • Export to PDF
Cause

Role assigned to user account in ReadyForms does not grant permission to export templates

Resolution
  1. Log into ReadyForms Administration with system administrator account
  2. In the toolbar on the left side, scroll all the way down and select System Administration 
  3. Under the Users tab, highlight the affected account and click Update
    1. Make note of the role assigned to the account, then click Cancel
  4. Navigate to the Roles tab and highlight the role you noted above
    1. Click Update
    2. Check off Can Export Templates 
    3. Click Save
  5. Have the affected user sign out and close all browser windows. They will be able to export when they sign back in.
Additional Information

This particular error differs from the blinking 401 outlined in Blinking 401 in ReadyForms or Tyler 311.