Schedule Is Not Applying To Timesheet



Description of Issue

The employee has a schedule set applied to their profile and selected to default timesheet from schedule but it does not always display their prepopulated schedule.



Context
  • ExecuTime

  • Time & Attendance

  • Timesheet Entry

  • Schedule Set



Cause

When an employee logs any time on the timesheet before saving their schedule, it will remove the unsaved schedule set unless you have the following flag enabled under UI →Time Processing Tab "Always default the timesheet from the schedule"



Resolution

In order to have the schedule set apply to the timesheet with asterisks next to each day:

  1. Navigate to System Admin

  2. Select UI Environment Flags 

  3. Select Time Processing Tab

  4. Scroll down and check the box for "Always default the timesheet from the schedule"

  5. Click Save

  6. Sign out and back into the Application

  7. Navigate to Employee Actions → Timesheet Entry

  8. Notice that the schedule set is now showing up for the rest of the days in the schedule. 




Additional Information