Cashiering External Systems Not Loading After Update to 2021.10



Description of Issue
  • Cashiering external systems page will not load. The page continuously spins but no information loads. 

  • Debug logs show the following error after trying to open External Systems:

    • Member Name:Get; File Path:C:\BuildAgent\work\d1c61111a5328724\Web\Tyler.Cashiering.UI.Web\Controllers\OData\Administration\ExternalSystemsController.cs; Line Number:33 ExternalSystemsController.Get Exception (System.InvalidOperationException): Sequence contains no matching element

  • In IIS, the cashiering api application pools will not stay started.

    • 'train.cashiering.creditcardprocessorapi'

    • 'train.cashiering.integrationapi'

    • 'train.cashiering.reportapi'



Context
  • Cashiering 2021.10



Cause

Microsoft Monitoring Agent is installed on the server, causing the application pools to load DLL’s from the following location:

C:\Program Files\Microsoft Monitoring Agent\Agent\APMDOTNETAgent\V8.0.13053.0\x64\Microsoft.ApplicationInsights.ExtensionsHost_x64.dll



Resolution

Uninstall Microsoft Monitoring Agent from Control Panel > Programs and Features



Additional Information