Holiday Not Applying To Timecard



Description of Issue

The Holiday Schedule was applied to the correct users and they have access to the pay code but it did not apply to their timecard.



Context
  • ExecuTime

  • Time & Attendance

  • Holiday Schedule



Cause

The reason why the Holiday Schedule did not apply to the user is because the pay code is marked as an accrued benefit and the user does not have a balance of that code.



Resolution

In order to have the Holiday Schedule applied to the users timecard:

  1. Navigate to System Admin → Master File Management → Pay Codes

  2. Select the Pay Code in question by clicking the pencil icon

  3. Under Benefit Settings, Select the drop-down for Benefit and select Non-Accrued

  4. Scroll down and click Save

  5. Navigate back to Payroll Functions → Holiday Schedule

  6. Delete the Holiday Schedule that was previously submitted and resubmit a new Holiday Schedule, this will allow the entry to be populated on the timecard due to not having to have a balance of the code.


If you do not want to mark the pay code as being non-accrued:

  1. Make sure that the user has a balance on their payroll system.

  2. Navigate to System Admin → Scheduled System Jobs

  3. Select the Cloud & Arrow Icon to manually kick of the Benefit Integration → Wait for the integration to finish

  4. Navigate to Employee Actions → Benefits Summary

  5. Notice that the pay code and balance is displaying on this screen

  6. Navigate back to Payroll Functions → Holiday Schedule

  7. Delete the Holiday Schedule that was previously submitted and resubmit a new Holiday Schedule, this will allow the entry to be populated on the timecard due to now having a balance of the code.




Additional Information